Completed
California (LAX1) network upgrade

Status
Resolved after about 1 hour
Started
June 18, 2022 at 8:45 AM
Completed
June 18, 2022 at 9:58 AM
Affects
Core Networks
California, USA (LAX1)
  • Completed
    June 18, 2022 at 9:58 AM

    Maintenance has now been completed! All service are back online.

    If you still seeing issues, please let us know.

  • In progress
    June 18, 2022 at 8:45 AM

    We are currently performing network enhancements in our California (LAX1) location.

    You might experience a few networks hiccups during this time!

    ETA for completion: 30-45 minutes