Scheduled for January 11, 2025 at 6:00 PM – January 26, 2025 at 10:00 PM
Affects
Core Networks
Under maintenance from 6:00 PM to 10:00 PM
Reston, Virginia (IAD1)
Under maintenance from 6:00 PM to 10:00 PM
Ashburn, Virginia (IAD2)
Under maintenance from 6:00 PM to 10:00 PM
Completed
January 26, 2025 at 10:00 PMCompleted
January 26, 2025 at 10:00 PMMaintenance has been completed. All affected customers have been notified via personalized ticket at this time.
If you still experiencing any issues, please let us know via ticket!
Thank you for your patience and understanding on this matter.
Update
January 25, 2025 at 6:23 PMIn progress
January 25, 2025 at 6:23 PMMaintenance is currently in progress, our team will post updates as we complete by phases according to the personalized notification via ticket.
It is expected that your server network might be interrupted up to 40 minutes during this time.
Please let us know via ticket if you have any questions!
Update
January 19, 2025 at 4:00 PMIn progress
January 19, 2025 at 4:00 PMMaintenance is 85% completed at this time and has been extended to end of January 27th 2025 in order to minimize impact to clients usage during business days.
Our team will perform maintenance on the last server batches next weekend. Affected servers were not affected this weekend as the maintenance of other batches were taking longer than expected.
Thank you for your patience and understanding on this matter!
Update
January 18, 2025 at 8:00 PMIn progress
January 18, 2025 at 8:00 PMMaintenance is currently in progress, our team will post updates as we complete by phases according to the personalized notification via ticket.
It is expected that your server network might be interrupted up to 40 minutes during this time.
Please let us know via ticket if you have any questions!
Update
January 13, 2025 at 4:00 PMIn progress
January 13, 2025 at 4:00 PMMaintenance for this weekend has been concluded. We will notify affected customers for next weekend.
Thank you for your patience and understanding!
If you still experiencing issues, please let us know via tickets.
In progress
January 11, 2025 at 6:05 PMIn progress
January 11, 2025 at 6:05 PMMaintenance is now in progress.
Planned
January 11, 2025 at 6:00 PMPlanned
January 11, 2025 at 6:00 PMOur team will be performing network upgrade in the following days:
January 11th 2025
January 12th 2025
January 18th 2025
January 19th 2025
It's expected that network might be disrupted for up to 20 minutes at times during this maintenance as we shift loads between upstreams and and upgrade network core routers to new hardwares. We've planned this maintenance carefully and will do everything in our control to minimize the downtime.
This maintenance is required for us to add new capacity in our network and eliminates all potential network congestions in the future.
Our team will provide new updates as we proceed with the maintenance.
Please let us know if you have any questions!!