Completed
Software and hardware upgrade in Virginia

Status
Resolved after 15 days
Started
August 04, 2022 at 8:29 PM
Completed
August 19, 2022 at 10:03 PM
Affects
Virginia, USA (IAD1)
  • Completed
    August 19, 2022 at 10:03 PM

    We've finally completed the maintenance on all service in Virginia!

    If you have any questions, please let us know via our support ticket.

    Thank you for your patience and understanding on this matter.

  • Update
    August 17, 2022 at 5:47 PM

    We are looking to perform maintenance on servers under the following nodes:

    US-VA-1 to US-VA-13 (total 13 nodes).

    If you have any further questions, please let us know via ticket!

  • Update
    August 17, 2022 at 1:51 AM

    We've completed maintenance on the following nodes:

    US-VA-241 to US-VA-252 (total 12 nodes)

    Thank you for your patience and understanding.

    If you have any further questions, please let us know via ticket!

  • Update
    August 16, 2022 at 11:35 PM

    We've completed maintenance on the following nodes:

    US-VA-157 to US-VA-168

    US-VA-197 to US-VA-224

    US-VA-281 and US-VA-283

    We are looking to perform maintenance on servers under the following nodes:

    US-VA-241 to US-VA-252 (total 12 nodes)

    If you have any further questions, please let us know via ticket!

  • Update
    August 16, 2022 at 3:49 PM

    We are looking to perform maintenance on servers under the following nodes:

    US-VA-157 to US-VA-168

    US-VA-197 to US-VA-224

    US-VA-281 and US-VA-283

    Total 42 nodes.

    If you have any further questions, please let us know via ticket!

  • Update
    August 15, 2022 at 8:14 PM

    The maintenance of server: US-VA-185 to US-VA-196, US-VA-282 has now been completed!

    The next server list will be announced very shortly!

    Thank you for your patience and understanding.

  • Update
    August 15, 2022 at 12:37 PM

    We've completed maintenance on servers: US-VA-169 to US-VA-184 and will continue maintenance on servers: US-VA-185 to US-VA-196, US-VA-282 in 2 hours.

    If you have any further questions, please let us know via ticket!

  • Update
    August 15, 2022 at 11:05 AM

    We've completed maintenance on servers: US-VA-141 to US-VA-156, we couldn't do maintenance on US-VA-157 to US-VA-168, US-VA-283 due to unexpected technical issues.

    We are looking to perform maintenance on servers under the following nodes next:

    US-VA-169 to US-VA-196, US-VA-282 (total 29 nodes).

    If you have any further questions, please let us know via ticket!

  • Update
    August 15, 2022 at 9:24 AM

    We are looking to perform maintenance on servers under the following nodes:

    US-VA-141 to US-VA-168, and US-VA-283 (total 29 nodes).

    If you have any further questions, please let us know via ticket!

  • Update
    August 14, 2022 at 9:52 PM

    We were only able to perform maintenance on the following servers:

    US-VA-129 to US-VA-140, US-VA-284, US-VA-225 to US-VA-240

    The following will be rescheduled tomorrow: US-VA-241 to US-VA-252

    Please let us know via ticket if you have any further questions!

    Thank you for your patience and understanding.

  • Update
    August 14, 2022 at 4:12 PM

    We are looking to perform maintenance on servers under the following nodes:

    US-VA-129 to US-VA-140, US-VA-284 US-VA-225 to US-VA-252

    Total: 41 nodes

    If you have any further questions, please let us know via ticket!

  • Update
    August 14, 2022 at 10:20 AM

    The maintenance of US-VA-269 to US-VA-280 has now been completed!

    We are looking to perform maintenance on servers under the following nodes:

    US-VA-57 to US-VA-61 (total 5 nodes).

    If you have any further questions, please let us know via ticket!

    Thank you for your patience and understanding.

  • Update
    August 14, 2022 at 7:19 AM

    We are looking to perform maintenance on servers under the following nodes:

    US-VA-269 to US-VA-280 (total 12 nodes).

    If you have any further questions, please let us know via ticket!

  • Update
    August 13, 2022 at 1:35 PM

    The maintenance of US-VA-253 to US-VA-268 has now been completed!

    The next server list will be announced very shortly!

    Thank you for your patience and understanding.

  • Update
    August 13, 2022 at 11:38 AM

    We've completed maintenance on US-VA-285 to US-VA-312 (total 28 nodes).

    Our team is required to perform maintenance US-VA-263 to US-VA-268 alongside with US-VA-259 to US-VA-262 due to the cabinet was not secured enough, we will need to derack entire half-cab to make sure all servers are re-racked properly.

    Thank you for your understanding!

  • Update
    August 13, 2022 at 10:42 AM

    Our team has almost completed maintenance of US-VA-285 to US-VA-312 (total 28 nodes).

    We are looking to perform maintenance on US-VA-259 to US-VA-262 next!

    Please let us know via ticket if you have any questions!

  • Update
    August 13, 2022 at 7:08 AM

    We are looking to perform maintenance on servers under the following nodes:

    US-VA-285 to US-VA-312 (total 28 nodes).

    If you have any further questions, please let us know via ticket!

  • Update
    August 12, 2022 at 2:05 PM

    The maintenance of US-VA-253 to US-VA-258 has now been completed!

    The next server list will be announced very shortly!

    Thank you for your patience and understanding.

  • Update
    August 12, 2022 at 12:00 PM

    The maintenance of US-VA-123 to US-VA-128 and US-VA-313 to US-VA-328 has now been completed!

    Our team is looking to perform maintenance on US-VA-253 to US-VA-258 (6 nodes) at this time.

    Thank you for your patience and understanding.

  • Update
    August 12, 2022 at 9:10 AM

    We were only able to perform maintenance on US-VA-123 to US-VA-128 and US-VA-284 due to lack of equipment available to fix unexpected issues that might arise. The rest will be rescheduled later on!

    Our team is looking to perform maintenance on US-VA-313 to US-VA-328 (16 nodes) at this time.

    If you have any further questions, please let us know via ticket!

  • Update
    August 12, 2022 at 6:50 AM

    We are looking to perform maintenance on servers under the following nodes:

    US-VA-123 to US-VA-140 and US-VA-284 (total 19 nodes).

    If you have any further questions, please let us know via ticket!

  • Update
    August 11, 2022 at 12:36 PM

    The maintenance of US-VA-371 to US-VA-396 has now been completed!

    The next server list will be announced very shortly!

    Thank you for your patience and understanding.

  • Update
    August 11, 2022 at 10:36 AM

    The maintenance of US-VA-387 to US-VA-424 has now been completed!

    We are looking to perform maintenance on servers under the following nodes:

    US-VA-371 to US-VA-396 (total 26 nodes).

    If you have any further questions, please let us know via ticket!

    Thank you for your patience and understanding.

  • Update
    August 11, 2022 at 6:23 AM

    We are looking to perform maintenance on servers under the following nodes:

    US-VA-397 to US-VA-424 (total 28 nodes).

    If you have any further questions, please let us know via ticket!

  • Update
    August 10, 2022 at 4:21 PM

    The maintenance of US-VA-62 to US-VA-72 has now been completed!

    The next server list will be announced very shortly!

    Thank you for your patience and understanding.

  • Update
    August 10, 2022 at 12:33 PM

    We are looking to perform maintenance on servers under the following nodes:

    US-VA-62 to US-VA-72 (total 11 nodes).

    If you have any further questions, please let us know via ticket!

  • Update
    August 09, 2022 at 9:05 PM

    The maintenance of US-VA-113 to US-VA-122 has now been completed!

    We were not able to do maintenance on US-VA-123 to US-VA-128 due to unexpected issue. Those nodes will be rescheduled shortly!

    The next server list will be announced very shortly!

    Thank you for your patience and understanding.

  • Update
    August 09, 2022 at 1:40 PM

    We are looking to perform maintenance on servers under the following nodes:

    US-VA-113 to US-VA-128 US-VA-122 (total 16 10 nodes).

    If you have any further questions, please let us know via ticket!

  • Update
    August 08, 2022 at 11:37 PM

    The maintenance of US-VA-73 to US-VA-84 has now been completed!

    The next server list will be announced very shortly!

    Thank you for your patience and understanding.

  • Update
    August 08, 2022 at 9:25 PM

    We are looking to perform maintenance on servers under the following nodes:

    US-VA-73 to US-VA-84 (total 12 nodes).

    If you have any further questions, please let us know via ticket!

  • Update
    August 08, 2022 at 4:29 PM

    The maintenance of US-VA-100 to US-VA-112 has now been completed!

    The next server list will be announced very shortly!

    Thank you for your patience and understanding.

  • Update
    August 08, 2022 at 2:43 PM

    We are working on VA-104, 105, 109, 110 at the moment.

    Those nodes are down longer than expected due to drive degrades and our team is working to replace those!

    The other nodes should already be completed as expected.

  • Update
    August 08, 2022 at 10:35 AM

    We are looking to perform maintenance on servers under the following nodes:

    US-VA-100 to US-VA-112 (total 13 nodes).

    If you have any further questions, please let us know via ticket!

  • Update
    August 06, 2022 at 9:35 PM

    The maintenance of US-VA-85 to US-VA-99 has now been completed!

    The next server list will be announced very shortly!

    Thank you for your patience and understanding.

  • Update
    August 06, 2022 at 6:35 PM

    We are looking to perform maintenance on servers under the following nodes:

    US-VA-85 to US-VA-99 (total 15 nodes).

    If you have any further questions, please let us know via ticket!

  • Update
    August 05, 2022 at 11:05 PM

    The maintenance of US-VA-40 to US-VA-56 has now been completed!

    US-VA-56 took longer than expected as there were minor hardwares issues, which was then fully replaced.

    The next server list will be announced very shortly!

  • In progress
    August 04, 2022 at 8:29 PM

    We are looking to perform maintenance on servers under the following nodes:

    US-VA-40 to US-VA-56 (total 17 nodes).

    If you have any further questions, please let us know via ticket!

  • Planned
    August 04, 2022 at 8:29 PM

    We are looking to performing a quick software upgrade alongside with hardware upgrades (if spotted to have degraded performance), in order to ensure that performance keeps up with our standards in Virginia location.

    Specifically, the following will be achieved once the maintenance is completed:

    • All servers software are up-to-date.
    • Start supporting Windows 2019.
    • Replace degraded hardware components.
    • Adding second uplink to all servers, making the network completely redundant even from node level.

    The maintenance will start on 5th August. We will add updates on affected nodes few hours before the maintenance begins!

    As noted, our team is fully aware of customer's usage and will avoid doing maintenance on those timeframe.

    It's estimated that your server will become unreachable for ~10-20 minutes up to 2 hours, depending on if the node has failed hardwares or not. The server will still be running (not shutdown) during this time without internet access.

    Please let us know via ticket if you have any further questions!

    Edit: We've adjusted the estimated downtime to match with the realistic situation as we start the maintenance.